Poor performance while using the DSM Explorer
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Poor performance while using the DSM Explorer

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Article ID: 4151

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Updated On:

Products

CA Client Automation - IT Client Manager CA Client Automation

Issue/Introduction

We experience poor browsing performance in the DSM Explorer under 'Computers and Users' section.

Browsing any folder ends up in waiting for at least 30-60 seconds until a result is displayed.

Environment

Client Automation - All Versions

Cause

This could be due to several causes; there are some of possibilities:

1.  Low bandwidth between the DSM Explorer and the MDB (If the MDB is on a remote machine).

2.  System (very) busy with other installed applications or CAF components (like System Engine).

3.  Huge CFNOTSRVD.DAT file within CA\DSM\appdata folder
     This file contains CAM cache and routing information which may also sometimes contain invalid/expired messages.

4.  Problems with CAM communication (proxy enable).

5.  Poor hardware (slow and few processors, little memory, slow NIC).

6.  Some large queries executing on this Manager could causing several damage on the performance.

Resolution

Solutions to address those causes above listed.

1.  Low bandwidth between the DSM Explorer and the MDB (If the MDB is on a remote machine)

2.  System (very) busy with other installed applications or CAF components (like System Engine)

3.  Huge CFNOTSRVD.DAT file within CA\DSMappdata folder.
     This file contains CAM cache and routing information which may also sometimes contain invalid/expired messages.

          Deleting this file using the procedure below will clear out the CAM cache and routing information:      

  •     CAF STOP
  •     Delete the file CA\DSM\appdata\cfnotsrvd.dat
  •     camclose & cam start -c -l 
  •     CAF START
4.  From Domain Manager, verify that there are no reverse proxy messages in the cam logs,
       if so set disable_proxies = yes from the cam.cfg file.
 
       NOTE: If there are additions in ROUTING section do not do this as it disables that section

5.  Poor hardware (slow and few processors, little memory, slow NIC)

6.   Some large queries executing on this Manager could causing several damage on the performance; so if this fit with your case, check below a little procedure where  that can help you.

A.  Open the SQL Management Studio to execute the following query:

                   use mdb
select query_uuid, count ( * ) as cnt from ca_query_def_contents
group by query_uuid
order by cnt desc 

The query above check for queries that are very long or have a lot of conditional statements (and or, etc)

B.   Once you verify if you have "bad" queries you can get the "name" of through the following query.

SELECT * FROM CA_QUERY_DEF WHERE QUERY_UUID=SPECIFIC-UUID-FROM-ABOVE

          NOTE: Replace the "SPECIFIC-UUID-FROM-ABOVE" for the UUID value taked from the query result.

C.    You can then check in dsm explorer and see if do you is using the query and if not delete it or modify it to make it a smaller query.

D.   You can delete it by running this query as well

          DELETE FROM CA_QUERY_DEF_CONTENTS WHERE QUERY_UUID= SPECIFIC-UUID-FROM-ABOVE
          DELETE FROM CA_QUERY_DEF WHERE QUERY_UUID= SPECIFIC-UUID-FROM-ABOVE
 
7.    Call back interval (within configuration policy DSM > adminconsole) too high; it is recommended to stick with default value unless instructed by support personnel otherwise.